My Molly 2.3 is back for '15 - Mazda Forum
 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 01-13-2015, 10:01 PM Thread Starter
MazdaWorld Member
 
Join Date: Aug 2006
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Talking My Molly 2.3 is back for '15

Hi to you all. Figured I would fire up a new 2015 thread now that I just got my '99 S returned to the road after she was away from me for the last half of 2014.

A buddy of mine was installing the latest round of parts on da Molly for me. Refreshed the front end steering/suspension components .. Yet again. Plus she got the first tranny oil flush and fill, filter change since the tranny was rebuilt in mid 2010 @ ~115k miles. I'm now @ 154k. What took the most time and was big PITA was the changing of dead CV axles. Never could get either side free from the hub.

When I went to pick the car up yesterday I decided to stop by a huge U-pull yard to see what Millenia inventory they had. I was pleased to find an '01 2.3 which only arrived in the last week. I was like a pig rolling around in slop.. The car is a gold mine .. Everything still on it and extremely clean and well kept.

Bottom line is, I will be heading back to that yard later this week with my tools and many layers of clothes. Feel free to let me know if you have any parts request and I'll do my best to accommodate. If I remember correctly.. They had three Millys there .. Think it was 1 2.5L base and the 2 were 'S' 2.3's.. But the first two had been there for a while and we're picked over.

I grabbed coils, a marker light assy & the MILLER CYCLE ENGINE 'surge tank cover'... So far

Feels great to have Molly back on the road.
skyjockey70 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 01-14-2015, 08:16 AM
Silver Member
 
Join Date: Mar 2010
Location: Andover, MN
Posts: 773
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 23 Post(s)
Funny, I always feel that same way when I find a Millenia in the U-pull.
TomK

2001 Mazda Millenia 2.5L Champagne Silver Mica 190,000 miles
2002 BMW 530iA Sterling/black 95,000 miles
2006 Volvo XC70 Blue 136,000 miles
2001 Mazda Millenia 2.5L Brilliant Black 213,000 miles - SOLD
1993 Mazda 626 2.5L ATX 235,000 miles - SOLD
Kutcht1 is offline  
post #3 of 7 (permalink) Old 02-10-2015, 02:16 PM Thread Starter
MazdaWorld Member
 
Join Date: Aug 2006
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Strange side to side oscillations.. Any ideas??

Since getting my car back, I haven't been too impressed with the ride quality. Something seems to be inducing it to have a slight squirrelly-ness (seat of pants feel) when cruising at moderate speeds ie. 40-50 mph. I just had alignment done. But Firestone only set the toe to within specs. I should have insisted that they adjust the cambers also. Current cambers.. LF -1.3 .. RF -.9 &
LRr -1.9...RRr -1.7. All the cambers with exception of RF appear out of spec. Wondering if this could be the culprit??
skyjockey70 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 07-24-2016, 12:00 AM Thread Starter
MazdaWorld Member
 
Join Date: Aug 2006
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Update... Several months ago I decided to excercise the ole' adage .. If you want something done right, just do it yourself. .. Even though I paid $180 for a lifetime alignment & the cambers at all four corners are surely adjustable. So I used the data available in the FSM regarding how many degrees/minutes each tick Mark is worth on the camber eccentric bolt. I adjusted them so as to bring them into the spec range. LO & BEHOLD.. it took away my side to side sway which was making me nauseous. In the process of adjusting the rear cambers it was necessary to turn the eccentric bolt to the max tick Mark shown. I figured that must be due to the bushing in those link arms to be excessively worn so I ordered those from the dealer. They run about $90 each with my 25% discount.
skyjockey70 is offline  
post #5 of 7 (permalink) Old 05-07-2017, 01:33 PM Thread Starter
MazdaWorld Member
 
Join Date: Aug 2006
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Update**

Finally got my Black 99S returned to the road after it had a heater hose burst back in August. I pulled the RH CV axle since it had what appeared to be a slashed boot perpendicular to the bellows. Got a New GSP axle from Advance Auto for $50. I managed to distort the threads on the ball joint end of the lateral link when changing the axle.

Just happy to have car back in action after having it garaged for last 9 months. 178k on the clock.
skyjockey70 is offline  
post #6 of 7 (permalink) Old 05-10-2017, 01:41 PM
Junior Member
 
Pugheaven's Avatar
 
Join Date: Sep 2015
Location: Holywell (UK)
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Send a message via Skype™ to Pugheaven
Quote:
Originally Posted by skyjockey70 View Post
Update**

Finally got my Black 99S returned to the road after it had a heater hose burst back in August. I pulled the RH CV axle since it had what appeared to be a slashed boot perpendicular to the bellows. Got a New GSP axle from Advance Auto for $50. I managed to distort the threads on the ball joint end of the lateral link when changing the axle.

Just happy to have car back in action after having it garaged for last 9 months. 178k on the clock.
Lets have some piccies then :-)

2000 Xedos 9/Millenia 2.3 Super Charged
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Champagne Silver Mica

18" Fox FX10 Alloys
235/40/18 Continental Sport Contact 5's
H&R 40mm Lowering Springs
Painted/Logo Red Calipers/EBC Pads
Cross Drilled & Grooved Discs
Double Din 6.4" SAT NAV/Stereo
Pugheaven is offline  
post #7 of 7 (permalink) Old 05-16-2017, 08:32 PM Thread Starter
MazdaWorld Member
 
Join Date: Aug 2006
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
I'll try to get some pics of car on here. Right now it is kicking my butt. I gave it a new RH Axle and replaced the heater hose. And apparently I'm going to have to make time to do the valve cover gaskets next cuz cylinders 1&2 have major amounts of oil in the plug wells and 3&4 have some also. It will be my first go at doing the VCG's. All the oil around the plugs is causing terrible misfiring of the engine. I was hoping to be able to drive it through the summer and tackle that job in Fall. Oh well.
skyjockey70 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome