Who has the most miles/problems on their Milly? - Page 3 - Mazda Forum
Reply
 
LinkBack Thread Tools
post #21 of 560 (permalink) Old 04-09-2003, 08:12 AM
Junior Member
 
Join Date: Aug 2002
Location: Boston, MA
Posts: 428
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to MilleniaFalcon Send a message via Yahoo to MilleniaFalcon
1998 2.5, Indigo Blue
Bought 7/2/02 w/37k mi, now 46k mi
Aftermarket: K&N filter, Accel wires, mud guards, sunroof visor, Tornado, PIAA
Problems: replaced 2 tires which had huge bubbles on the sidewalls($180 tire+labor), replace broken vacuam sensor($60), and just found out I need to replace or repair one of my cracked rims. My motorized steering column is no longer motorized. Think the motor died, but I set the steering wheel where I want it. The car drifts very slightly to the left. Gonna need a alignment soon. My gas mileage sucks. I got a scratch on my rear left door caused by a stupid driver who doesn't know how to pull out of a parking lot. The beige leather seats are getting dirty. Recent major tune-up interval($329). Replaced cheap Anco wipers with Bosch($20). After a few months after purchasing the Milly, I noticed the front left fender is darker than the OEM blue. The car was probably in a accident. I plan to repaint the whole car. All in all, I have no problems with the engine yet. The engine is the most important to me. Hard to believe it's a Ford motor powering the base Millenias. So, with a Ford engine, you'll never when it'll go on you. Just don't miss the tune up intervals and maybe it'll last to 200k.

New England Patriots. Super Bowl 39 Champions! 2/6/05
Boston Red Sox. 2004 World Series Champions! 10/27/04
MilleniaFalcon is offline  
Sponsored Links
Advertisement
 
post #22 of 560 (permalink) Old 04-18-2003, 08:11 PM
Junior Member
 
Join Date: Apr 2003
Posts: 203
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
75,000 miles. stutter and burning gas, check engine light every other week, car doesnt pull hard each time I accelerate.

Total Hp 294[/b]. <span style=\'color:red\'>For Photoshopped Pics Click
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
20zMilleniaS is offline  
post #23 of 560 (permalink) Old 04-18-2003, 09:56 PM
Platinum Member
 
Join Date: Apr 2003
Location: New Orleans, Louisiana
Posts: 11,865
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via Yahoo to dark angel
1999 2.5L
purchased with 37,588 miles, now has 41,700.
I've only had the car for 2 and a half months. No major problems really but i guess that's because the car hasn't hit that halfway mark yet. Is it true the 2.5 engine is made by ford? I thought the car was manufactured in Japan? If so, what can I do extra to make sure I have no major problems with the Fix Or Repair Daily engine?

Brilliant Black/Biege
dark angel is offline  
post #24 of 560 (permalink) Old 04-24-2003, 08:51 PM
Mazda Newbie
 
Join Date: Jul 2002
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via MSN to Kyle
Class: P
Year: 2002
Miles when purchased: 8 miles
Miles to date: 14,500 miles
No problems as of yet

Major Mods: HID Conversion Kit
Minor Mods: PIAA fogs
Wheels were in the future, but now I'm looking at a GSXR 750 fun toy.
Wheels postponed to maybe next summer.

Owner of:

2002 platinum silver millenia
Kyle is offline  
post #25 of 560 (permalink) Old 05-21-2003, 11:44 AM
Junior Member
 
weedget's Avatar
 
Join Date: May 2003
Posts: 172
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Year: 1995 (2.5L Golden Edition)

Mileage: 108 990

Owned: 3 months

Major problems I've encountered:

- had my tranny rebuilt two weeks ago (service guys said that due to the "HOLD" button misuse. The previous owner used it instead of knock down button under the accelerator and didn't change transmission fluid and filter throughout 4 years)
- steering wheel power tilt is dead (luckily in the downright position)
- both fog lights doesn't work (don't know yet wether it's the bulbs, fuse or wiring)
- sometimes a squeeky noise comes from the brakes. It occurs only when I go backwards with the steering wheel turned maximum to the left or right and I got a feeling that the brake pedal goes up when this noise occurs - am I having illusions or does anybody encountered it

Apart form that I really enjoy that car, it drives and handles excellent. Best car I ever had
weedget is offline  
post #26 of 560 (permalink) Old 06-12-2003, 12:15 PM
Mazda Newbie
 
Join Date: Jun 2003
Location: Kansas City, Missouri
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hi everyone, I'm the new guy here.

I am trying to sell my current car, when I do I'm going to take over my mom's 1995 millenia. Here's the info on the car:

1995 Pearl White millenia S
(Manufacture date on sticker is May 1994, one of the very first)
And for those of you that are concerned about the S model's reliability, this car has 140,000 miles on it. Other than a water pump and a radiator crack the engine has been perfect. The car around it is falling apart because she never took the best care of it though.

I hope this web site picks up, I'm planning on doing a lot of work to fix up this car and I'll be interested in sharing with everyone.

Ryan
RyanS is offline  
post #27 of 560 (permalink) Old 06-12-2003, 01:50 PM
Mazda Newbie
 
Join Date: May 2003
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2002 P Model
4 seasons package

31 Miles when bought.

1400 Miles now.
Smitty1269 is offline  
post #28 of 560 (permalink) Old 06-12-2003, 02:06 PM
Mazda Newbie
 
Join Date: Jun 2003
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I had some brake work done. My steering tilt motor is going out. Taking it in next week. I am glad I have an extended warranty. Other than that I have no major problems w/ my car. This car rides and drives great. Best car I have owned.

PS- the tornado fuel saver works
eviltyrant7 is offline  
post #29 of 560 (permalink) Old 06-23-2003, 04:09 AM
Junior Member
 
Join Date: Jan 2003
Location: Long Island NY
Posts: 122
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to GQ79
Well it seems like every month i have another problemmm..lets see about a month ago i had a new tranny put in and seriously I wasnt 2 happy with it...it wasnt very smooth when it shifted...butttttt This past week my Timin belt jumped and I lost alot of power..so my mechanic fixed the problem and now the car is runnin amazin..no more hard shifting ....now the remus exhaust sounds even better...

98 Mazda Millenia L
Mods-K&N filter, remus exhaust.
ICE:Alpine HU,A/D/S 6X100 amp,Focal comp and MB Quart components. Almost in...
Exterior-Clear side markers, super plasma lights, 20% tint up front, 5% on rear(limo
GQ79 is offline  
post #30 of 560 (permalink) Old 07-01-2003, 12:32 PM
Mazda Newbie
 
Join Date: Jun 2003
Posts: 40
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Mine is a '95 L with 171,000 miles. Have had it since new. Only put 5,000 miles on during past 18 months. Used to commute 130 miles a day; just going up and down I26 between Spartanburg SC and Asheville NC. Company closed down last May, therefore the low miles during past year and 1/2. Still have factory brake pads on. Never any brake work done. Still looks like new inside. Never had an accident and paint still looks really good except hood which has numerous rock chips from all the highway driving, but nothing down to the metal.
Cruise has not worked since '96. Had the car serviced for that many times until I hit 60,000 and warranty ran out and I finally gave up. Really haven't missed it though. The factory 6-CD changer gave up three years ago. Dealer traced it to faulty wiring harness. Replaced it with an Alpine unit since new harness and labor was quoted $2,500.
I still enjoy the looks of my Millenia and think it performs best on long trips because it is comfortable and quiet.
I traded in a '93 SHO and there was no contest comparing workmanship (except for that great looking 220 HP Yamaha 8,000 rpm V6). But I was looking for a comfortable commute after my job transferred to NC.
legend700 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome