Who has the most miles/problems on their Milly? - Page 56 - Mazda Forum
Reply
 
LinkBack Thread Tools
post #551 of 560 (permalink) Old 04-10-2013, 09:25 PM
Mazda Newbie
 
Join Date: Mar 2013
Location: san diego
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Just got my car with 15k but im going to put a good amount on it since i drive and have trips everywhere
zoomzoom_mazda6 is offline  
Sponsored Links
Advertisement
 
post #552 of 560 (permalink) Old 06-10-2014, 07:08 PM
Mazda Newbie
 
christianglz956's Avatar
 
Join Date: Jun 2014
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
I have 99s
Milage: 22x,xxx
Got it 1year and 1 month
Put 80,000 since I had it😁
Problems;
-ignition coil
-cv axcel
- tie rod ends ball joints bearing and upper control arm.( both sides)
-TCS sensor (which is still on) any ideas?
--Fog lights (still don't turn on and I swapped the switch and relay already)
-supercharger ( rebuilt and replaced)
Other than this it runs like a champ beat a scion tc last night pretty proud of my girl ❤️


Sent from AutoGuide.com Free App
christianglz956 is offline  
post #553 of 560 (permalink) Old 07-13-2015, 05:53 AM
Mazda Newbie
 
Join Date: Feb 2015
Location: Near Sandhurst U.K>
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
I have a 2000 Xedos 9 2.3 (I'm in the U.K.) I have had it for about 10 years. It has 140K miles on the clock. No real problems. I had a transmission fluid leak from a fractured metal pipe just where the flexible pipe joins down at the bottom of the radiator, fixed it before the gearbox suffered. Just had a coil pack go faulty. The problem here is it is a very rare car in the U.K. so practically no second hand spares to be found. Just remembered it leaked water into the spare tyre well, turned out to be a body seam not perfectly sealed down by the rear light cluster. I had to strip out the rear seats and climb in with a torch whilst my wife hosed the car with water.
joeinblackwater is offline  
post #554 of 560 (permalink) Old 07-20-2015, 12:21 AM
Mazda Newbie
 
Join Date: Jul 2015
Location: This world of mazdas
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Just got mines I really want to hook it up
2002 millennia s
97k
marteeno88 is offline  
post #555 of 560 (permalink) Old 11-05-2015, 12:17 PM
Mazda Newbie
 
Join Date: Aug 2015
Location: Omaha NE
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2002 Milly 'S' bought it this summer for my teenage son with 60k miles on it, am in the middle of timing belt job, waiting on o-rings for water outlet. Had a vibration while driving, turned out to be defective driver-side driveshaft that previous owner had just replaced, bad aftermarket part. Otherwise ok so far.
trelain is offline  
post #556 of 560 (permalink) Old 11-10-2015, 08:18 PM
Junior Member
 
Pugheaven's Avatar
 
Join Date: Sep 2015
Location: Holywell (UK)
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Send a message via Skype™ to Pugheaven
Cool

Quote:
Originally Posted by joeinblackwater View Post
I have a 2000 Xedos 9 2.3 (I'm in the U.K.) I have had it for about 10 years. It has 140K miles on the clock. No real problems. I had a transmission fluid leak from a fractured metal pipe just where the flexible pipe joins down at the bottom of the radiator, fixed it before the gearbox suffered. Just had a coil pack go faulty. The problem here is it is a very rare car in the U.K. so practically no second hand spares to be found. Just remembered it leaked water into the spare tyre well, turned out to be a body seam not perfectly sealed down by the rear light cluster. I had to strip out the rear seats and climb in with a torch whilst my wife hosed the car with water.
I'm a fellow Uk'er matey! Keep her going!

2000 Xedos 9/Millenia 2.3 Super Charged
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Champagne Silver Mica

18" Fox FX10 Alloys
235/40/18 Continental Sport Contact 5's
H&R 40mm Lowering Springs
Painted/Logo Red Calipers/EBC Pads
Cross Drilled & Grooved Discs
Double Din 6.4" SAT NAV/Stereo
Pugheaven is offline  
post #557 of 560 (permalink) Old 11-25-2015, 08:49 AM
Mazda Newbie
 
Join Date: Nov 2015
Location: Gainesville, Florida
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by christianglz956 View Post
I have 99s
Milage: 22x,xxx
Got it 1year and 1 month
Put 80,000 since I had it😁
Problems;
-ignition coil
-cv axcel
- tie rod ends ball joints bearing and upper control arm.( both sides)
-TCS sensor (which is still on) any ideas?
--Fog lights (still don't turn on and I swapped the switch and relay already)
-supercharger ( rebuilt and replaced)
Other than this it runs like a champ beat a scion tc last night pretty proud of my girl ❤️


Sent from AutoGuide.com Free App
Hi Chris!

Looks like you're putting on about 7500 miles every 2 1/2 months. You got a ton of mileage on that car. That's impressive!

Do you change oil every 7500 with synthetic oil or do you use regular motor oil every 3000 miles or approximately every 4-5 weeks?

Do you add sea foam motor oil treatment in you tank to help keep your injectors and upper cylinder clean of carbon, and do you add sea foam to your crankcase a few days before you do an oil change? If you don't you might consider doing this to keep all oil passages clear of debris out of your Lysholm compressor, since you have already had to replace the compressor.

I have read on forum where guy rebuilt the compressor or the S/C, and the crud he found in the oil return port, which causes oil to accumulate in the compressor compartment and oil to be burnt during ignition and I immediately thought of using the sea foam prior to oil changes and how that would help reduce or eliminate these blockage problems.

I have also read that this engine should only use regular unleaded gasoline and using high quality synthetic oil in helping extend the life of this engine, as well as the Lysholm compressor as it looks or sounds like this may have been done in the past, or it would not have such high mileage, and except for the replacement of the SC/compressor it all sounds good.

I suppose you have a scan tool? If you are getting TCS off lights; on you might want to check you vacuum hose connections to the air bypass solenoids (vent and vacuum) and especially if you are getting P1526/1540 and you're getting them persistently along with an occasional P0170/0173. This is a huge problem.

BTW, the ABV vent solenoid and the ABV vacuum solenoid are located beside the EGR valve, behind the rear bank manifold, and if looking from front of car, and left to right, they are the second one (vent solenoid) and the fourth or last one to the right of that cluster of solenoids.

I have this problem (TCS off light coming on) and my car goes into limp mode which may also trigger a P0725. In the case of my 99 Milly S, I replaced the fuel filter, which was filthy as a pig pen, and also found it filled with dirt, and moisture droplets, and added antifreeze in radiator, and when I did that; it eliminated the TCS light off from coming on for a day. I went from over joyed to depressed. I am convinced I will find the filter plugged again.

I plan on getting a smoke test done on vacuum lines, to see if I have loose or disconnected vacuum hose(s) on the ABV vent/vacuum solenoids, before I make up my mind to replace them. I will also be checking fuel pressure, leakage at air tubes and possible plugged return lines from fuel pressure regulator. I will also use the sea foam additive every fuel fill up hoping to clean up the fuel on this pig and hopefully avoid dropping the fuel tank and having it cleaned. Iam hoping to make this pig into a lean mean running machine.

Lastly, you might to visit this sight and bookmark or favorite it:

milleniatech.net

Well Chris, that's my 3 cents on this subject. Thanks for reading my post and hope it helps you and others.

Good luck with your Milly! Take care
Gman9259 is offline  
post #558 of 560 (permalink) Old 01-07-2016, 08:30 PM
Junior Member
 
Join Date: Dec 2015
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
mine has 76k on it--driving me nuts-fix the solenoid-now it says abv circuit-love the car but its frustrating- oh yeah cv joint or joints bad--cold air hot heat-new tires-idk what to do with this car!!!
rooster1 is offline  
post #559 of 560 (permalink) Old 02-13-2016, 03:12 PM
Mazda Newbie
 
Join Date: Feb 2016
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have a 2000 Mazda Millenia. It has 195,000 miles. It started overheating, had the thermostat replaced and a hose replaced. It ran for a week then wouldn't crank up. I had the distributor and cap replaced along with the spark plugs... It crunk but once i cut it off it wouldn't crank again. What could possibly be the issue??
Tianac is offline  
post #560 of 560 (permalink) Old 11-07-2016, 11:07 PM
Mazda Newbie
 
Join Date: Aug 2015
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2001 Mazda Millenia S
175xxx KMs

Owned for 3-4 years

Problems

Misfiring due to broken ignition coil wire
Vacuum Leak -fixed
CV join -fixed
control arm -fixed
tie rod -fixed
another control arm-fixed
leaking PS cooler line -fixed
Leaking Rack and pinion -fixed
5 more pieces of suspension steering going out
Leaking VCG - fixed
Car will not accelerate well with more than 1/3 throttle
vacuum leak
AndrewM96 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome