High Idle - Mazda Forum

MazdaWorld.org is the premier Mazda Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 01-19-2009, 05:41 PM
Super Moderator
 
Join Date: Aug 2007
Location: Miami, Fl
Posts: 2,065
Default

Hey guys, I havent driven my car in over a week. So I go to turn on the car and I notice my idle is high at around 1200rpm, then I accelerated it in park and it stayed at around 1400rpm and it wont go lower. When I put it in reverse or drive the idle stablizes at around 800rpm. I am stumped.
I checked everywhere for a vac leak and couldnt find anything and since the idle is high I cant really hear anything to well. My CEL is on and I am going to autozone now to get it checked ill come back and tell you what the codes are.
Thanks
-Steven
__________________


<span style="font-family:Verdana">2001 Mazda Millenia L R.I.P
Reply With Quote
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 01-19-2009, 06:56 PM
Super Moderator
 
Join Date: Aug 2007
Location: Miami, Fl
Posts: 2,065
Default

Just came back from AutoZone and the codes were just for my failing cats. Which I will soon just cut off.
__________________


<span style="font-family:Verdana">2001 Mazda Millenia L R.I.P
Reply With Quote
  #3 (permalink)  
Old 01-19-2009, 06:59 PM
shikoku_iv@msn.com's Avatar
MazdaWorld Member
 
Join Date: Jan 2008
Posts: 358
Default

Quote:
Hey guys, I havent driven my car in over a week. So I go to turn on the car and I notice my idle is high at around 1200rpm, then I accelerated it in park and it stayed at around 1400rpm and it wont go lower. When I put it in reverse or drive the idle stablizes at around 800rpm. I am stumped.
I checked everywhere for a vac leak and couldnt find anything and since the idle is high I cant really hear anything to well. My CEL is on and I am going to autozone now to get it checked ill come back and tell you what the codes are.
Thanks
-Steven[/b]

I have the same problem with mine,assuming you have the MCE.My CEL is on constantly and I always get the same code P0505:Idle air control malfunction. It's going to suck if I have to replace the IAC valve,The cheapest I've seen is Autozone and they want $650.00.Does anyone one know if the IAC valve from a 00 will work in a 01,there's a wrecked 00 in a junkyard close to Fort Hood and I'm pretty sure the junkyard doesn't want an insane amount of money either.
Reply With Quote
  #4 (permalink)  
Old 01-19-2009, 07:50 PM
Super Moderator
 
Join Date: Aug 2007
Location: Miami, Fl
Posts: 2,065
Default

Well I didnt get that code, in that case I hope its just a vacuum leak. And yea it should work the MCE didnt really chane from 00-01.
__________________


<span style="font-family:Verdana">2001 Mazda Millenia L R.I.P
Reply With Quote
  #5 (permalink)  
Old 01-19-2009, 08:48 PM
Gold Member
 
Join Date: Jan 2007
Location: Saskatoon, SK, CAN
Posts: 1,072
Default

Quote:
Just came back from AutoZone and the codes were just for my failing cats. Which I will soon just cut off.[/b]
Throw the non-foulers on the post O2 sensors - you're goiing to have too eventually to get the MIL to stay off.
__________________
- Jeff L.
2001 Mazda Millenia S
1985 Mazda RX-7 S
Reply With Quote
  #6 (permalink)  
Old 01-19-2009, 08:59 PM
Super Moderator
 
Join Date: Aug 2007
Location: Miami, Fl
Posts: 2,065
Default

Yea true I just havent seen the non-foulers anywhere. I would have to order them.

So is a vaccum leak the only possibility?
__________________


<span style="font-family:Verdana">2001 Mazda Millenia L R.I.P
Reply With Quote
  #7 (permalink)  
Old 01-19-2009, 09:39 PM
Gold Member
 
Join Date: Jan 2007
Location: Saskatoon, SK, CAN
Posts: 1,072
Default

It's probably a bigger possibilty than anything else.
__________________
- Jeff L.
2001 Mazda Millenia S
1985 Mazda RX-7 S
Reply With Quote
  #8 (permalink)  
Old 01-19-2009, 10:32 PM
Matt64341's Avatar
Silver Member
 
Join Date: Jun 2007
Location: New Hampshire
Posts: 991
Default

Is it like that even after the engine is hot? Mine always idles high when its cold, 1800 or so in very cold then it drops to around 1400 and slowly creeps down as the engine warms up. Even if it is 50-60 degrees outside it will hover around 1400 for a short amount of time. When hot it is around 600-700. It would take a while for the engine to actually get completely cool in Florida so it could be that it just never got cool enough all the way through for that to happen.
__________________

1995 Millenia S
Parts Now For Sale
http://forums.mazdaworld.org/100-mil...arts-sale.html
Reply With Quote
  #9 (permalink)  
Old 01-19-2009, 10:34 PM
Gold Member
 
Join Date: Jan 2007
Location: Saskatoon, SK, CAN
Posts: 1,072
Default

He says it won't go any lower than 1400rpm - I'd assume that's when the engine is warm too
__________________
- Jeff L.
2001 Mazda Millenia S
1985 Mazda RX-7 S
Reply With Quote
  #10 (permalink)  
Old 01-19-2009, 10:51 PM
Super Moderator
 
Join Date: Aug 2007
Location: Miami, Fl
Posts: 2,065
Default

Yes the engine was at opertating temp and it likes to stay at about 1400rpm after accelerating it in park or neutral, if you put it in drive or reverse it goes down to about 900rpm which is still high but better.

When backing out of the driveway when I make the switch from Reverse to Neutral to Drive it increases revs and jumps into drive.
__________________


<span style="font-family:Verdana">2001 Mazda Millenia L R.I.P
Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 06:41 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.