TCS ABS lights on and my Radiator fan is not working. - Mazda Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 02-19-2012, 10:47 AM Thread Starter
Banned
 
Join Date: Jul 2011
Location: Miami FL
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
TCS ABS lights on and my Radiator fan is not working.

I have a 2000 madza millenia S and i noticed that the TCS and ABS light came on after my mechanic swap my engine with a used one. i drove the car but didn't notice any performance change. I also noticed the car was over heating and when my mechanic check it out, he notice that both of my Radiator fan weren't working but my relay does. so what can be the problem
Buju1540 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-20-2012, 12:04 AM
Gold Member
 
bigb's Avatar
 
Join Date: Oct 2003
Posts: 1,460
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
vacuum lines are mis-routed. download the schematic in the tech section and go trace the problem
bigb is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mazda Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome