Loud air sound from timing belt area - Page 2 - Mazda Forum
Reply
 
LinkBack Thread Tools
post #11 of 13 (permalink) Old 11-07-2012, 06:57 PM Thread Starter
Silver Member
 
Join Date: Feb 2007
Location: Chi-Town
Posts: 514
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I don't think it's the vacuum hoses unless there is one in the timing belt area


19x8 ROH Fury Wheels with 225/35 continental extreme contact dws
4500k Phillips HID
Cold Air Intake (thanks to Yel-low)
Cross drilled rotors
35% tint
IT'S OKAY TO DROOL A LITTLE
jaystew is offline  
Sponsored Links
Advertisement
 
post #12 of 13 (permalink) Old 11-13-2012, 08:26 PM Thread Starter
Silver Member
 
Join Date: Feb 2007
Location: Chi-Town
Posts: 514
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It was the front idler pulley for the serpentine belt...


19x8 ROH Fury Wheels with 225/35 continental extreme contact dws
4500k Phillips HID
Cold Air Intake (thanks to Yel-low)
Cross drilled rotors
35% tint
IT'S OKAY TO DROOL A LITTLE
jaystew is offline  
post #13 of 13 (permalink) Old 11-14-2012, 01:48 AM
Gold Member
 
bigb's Avatar
 
Join Date: Oct 2003
Posts: 1,460
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
awesome! that should be an easy fix
bigb is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome