Burning Rubber Smell - Mazda Forum

MazdaWorld.org is the premier Mazda Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-03-2005, 01:32 PM
Junior Member
 
Join Date: Oct 2003
Posts: 205
Default

Hi All,
89 929 139000mi. Over the past couple of years I had a pretty bad burning rubber smell coming from the engine. Eventually I traced it to a timing belt problem (well traced is stretching it, the thing broke), and after a few times changing the belt I finally got it right by replacing everything with Mazda parts. The smell never really went completely away. It's not a acrid eye-stinging stink any more, mostly just a hot rubber smell. I know I am leaking oil at the PVC housing and at the distributor hole blanking plate on the passenger side of the engine. The driver's side VC gasket is also leaking a bit. I change oil every 3~4000 miles and only have to add if I've been pushing the car very hard, 80~90 for a few days. When popping the hood after a hot run to trace the smell I do see a little smoke coming from the back passenger side of the engine. My question, is the rubber burning smell maybe really an oil burning smell. Anyone had similar leaks that smelled more or less like burning rubber? I really don't want to have to disassemble the timing belt area again if I can ovoid it.
Thanks for any info.
Reply With Quote
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-04-2005, 11:10 AM
Junior Member
 
Join Date: Apr 2004
Posts: 176
Default

I think if you are seeing smoke and know there are leaks then you'd be better off trying to fix some of the leaking first. I could see where it might smell like rubber.

The PCV valve leak is one that caused me a lot of odor. The leak was so small you couldn't really see it leaking. It would fill up a little depression in the block right below it though and then fall off on to the exhaust. I found an article about Mazda MPV's that have the same engine and it showed how easy it was to changed. There is just an O ring keeping that stem from leaking. I think you take one bolt out and pull the PCV stem out and replace the O ring is all. You can try and tighted the VC bolts a little, that might help too. It did me.
__________________
1988 929
Reply With Quote
  #3 (permalink)  
Old 12-27-2005, 07:01 PM
Mazda Newbie
 
Join Date: Dec 2005
Location: Madison,wi
Posts: 9
Default

98 millenia S 100000k also smells like burning rubber from the engine after driving it for a while. the smell goes away and then comes back. does anyone know what might cause this?
Reply With Quote
  #4 (permalink)  
Old 12-28-2005, 09:45 AM
Banned
 
Join Date: Jan 2005
Location: The Hammer
Posts: 4,223
Send a message via ICQ to michaeltroysmith Send a message via MSN to michaeltroysmith
Default

Your milly running abnormally hot? Mine runs normally just above half on the dash temp gauge. I have to actually check my temps sometime with a laser thermometer. There is a LOT of rubber vaccum hoses running across the top of that S. Are you sure that your intercoolers are clean and have free access to air (besides the restricted air ducting I mean). Nothing hanging down near the exhaust manifolds?
Reply With Quote
  #5 (permalink)  
Old 12-30-2005, 01:31 PM
Mazda Newbie
 
Join Date: Dec 2005
Location: Madison,wi
Posts: 9
Default

Quote:
Your milly running abnormally hot? Mine runs normally just above half on the dash temp gauge. I have to actually check my temps sometime with a laser thermometer. There is a LOT of rubber vaccum hoses running across the top of that S. Are you sure that your intercoolers are clean and have free access to air (besides the restricted air ducting I mean). Nothing hanging down near the exhaust manifolds?
[/b]
I havent gone under to look at it my self (snowy) but im sure theres nothing hanging around the maifold. a friend of mine changes my oil for me and if there was something he'd probly see it. Over the weekend I traveled over 100 mi.(80mph)and back, and I don't recall smelling that smell at all the whole time. The next day went to the store and the burning smell came back... It comes and goes when ever. I dont have a clue?? does someone know??
Reply With Quote
  #6 (permalink)  
Old 01-27-2006, 07:27 AM
VFR Boy's Avatar
Mazda Newbie
 
Join Date: Oct 2005
Posts: 10
Default

I get this sometimes in my 89 HC too. Once there was a plastic bag caught up just behind the headers but it wasn't getting burnt so that wasn't it.

The voltmeter now shows 16V when I'm >2000rpm so maybe it's the rectifier/regulator bridge burning out????????

__________________
1997 Honda VFR800 (Red, of course)

1988 Mazda 929 (Silver)
236,000km
New wiper blades
Original stereo/tape deck, but no tapes
Rear speakers don't work any more
Tappet noise when cold
Standard rims, suspension and ride height
4 mismatched tyres
Runs great!
Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 02:57 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.