1992 Mazda Mx-3: NO SPARK!!! - Mazda Forum

MazdaWorld.org is the premier Mazda Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-05-2007, 10:19 PM
Mazda Newbie
 
Join Date: Jun 2007
Posts: 1
Default

Hey i am new to the website. I really need to find out what is wrong with my car. I have a 1992 Mazda mx-3 18.L V6. I have tried everything to get spark in the car. First i Checked the disributor and theres power going to it but no spark at the plug. I read up that these engines are common for ignitors going or distributors. Well im under the impression that an ignitor is int eh distributor am i right? Well so i got another distributor from a scrap yard to see if thats the problem. Well that did nothing there was still no spark. Car someone please help me out because i do not have the money to bring it to a machanic i have to pay for collage in sept. If anyone can help thanks
Reply With Quote
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-28-2007, 09:44 PM
Silver Member
 
Join Date: Jan 2007
Location: North Carliona
Posts: 626
Send a message via AIM to Netopia Send a message via Yahoo to Netopia
Default

Did you ckeck to the igntion coil
are you sure you are getting fuel to the injector's
How does the car sound when you turn the key
__________________
Reply With Quote
  #3 (permalink)  
Old 01-22-2008, 01:14 PM
Mazda Newbie
 
Join Date: Jan 2008
Location: Milwaukee,WI
Posts: 22
Send a message via AIM to klzejbone@aol.com
Default

get a reman distributer from a local auto parts store with a warrenty.

Jeremy
__________________
93 MX-3 GS, KLZE, T304E @ 5 psi + more
221.6 whp 219.0 wtq untuned
13.4 @ 108
http://www.cardomain.com/ride/2378198
Reply With Quote
  #4 (permalink)  
Old 12-13-2008, 01:09 PM
Mazda Newbie
 
Join Date: Dec 2008
Location: Victoria BC
Posts: 3
Send a message via MSN to cc1059@hotmail.com
Default

Hi, did you solve your problem, I have the same issue with my mx3?
Reply With Quote
  #5 (permalink)  
Old 12-15-2008, 06:01 PM
Silver Member
 
Join Date: Mar 2007
Location: Bear , Delaware
Posts: 757
Default

The distributors on the V6 engines tend to fry the coil. The solution is to get another distributor from a known running engine or buy new from the parts store. Also if you replace the rotor make sure you mark the firing tab location on the shaft ! There are 3 ways to install the rotor only one of them is right. For more information on the distributor problem and some solutions see the MX6/626 section or visit MX-3.com and search Distributor mod.
__________________
19 x 8 Katana GR-5's Wrapped in 235/35/19 General tires.
Alpine 9887 Imprint HU.
Kicker KX650.4 powering :
Eclipse 5 1/4 seperates up front.
Eclipse 6 x 9 's out back.
2 12" Kicker XPL's in a sealed box.
2 Cerwin Vega 2 channel amps :
amps bridged at 350 watts each.
LED lights in the turn signals and brake lights.
Custom mounted 32 LED panel in the 3rd brake light.
Blue LED lights in the interior.
5% limo on side windows and 35% on rear window (will be going to 5% soon).
Avistart 4300 remote start alarm.
8000K HID Headlights.

Coming soon: Drop springs , CD rotors , Headers , Custom exhaust , CAI and some new carpet. Oh and more LED's
Reply With Quote
  #6 (permalink)  
Old 09-12-2011, 05:57 PM
Mazda Newbie
 
Join Date: Sep 2011
Posts: 3
Default

Same issue here as well. Same car, same year, same motor.. Ended up being the distributor/coil/ignition module. Everywhere I've read, yes, they are common problems in the V6 MX3. Unfortunately, a refurbed one at an auto-parts store costs around $500. If you are lucky, you can find one at a junkyard. If not, Google it til you find the one I found for $130 with free shipping. (Sorry, I never bookmarked it) The same distributor is interchangeable as follows:

Ford Probe GT 2.5L
93-94 626 V6

These cars are hard to find too! Goodluck!

P.S.- Heard also that the 93 MX6 is interchangeable too, but I didn't add it to this list because I never confirmed it... give it a shot too
Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 04:25 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.