Turn fan speed up, A/C turns off! - Mazda Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 04-20-2008, 01:00 AM Thread Starter
Mazda Newbie
 
Join Date: Apr 2008
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My teenage son has a 1987 Mazda B2000 pickup. It recently developed a problem with the A/C. Starting at the fan speed in the off position and the A/C dash buton pushed "On": turn the fan speed up 1 notch. A/C compressor turns on, but fan doesn't run. Turn fan speed up to the next notch, AC compressor still on, still no fan. Turn fan speed up one more notch, fan comes on but A/C compressor turns OFF! Turn up one more notch (high speed), fan runs but A/C is still off. I replaced the fan speed controller switch (the switch attached to the dash knob) but it still does the exact same thing...so I'm assuming the problem isn't in fan speed switch. What else could make the fan not run on 2 notches, and the A/C not run on 2 notches??? Any help anyone could give would be GREATLY appreciated! Thanks.
gief223@sbcglobal.net is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-28-2008, 03:15 PM
Mazda Newbie
 
Join Date: Jun 2007
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
BUMP! I could use some help on this matter as well as mine does the same kinda!
oneyunguy@yahoo.com is offline  
post #3 of 4 (permalink) Old 06-29-2008, 08:40 PM Thread Starter
Mazda Newbie
 
Join Date: Apr 2008
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
BUMP! I could use some help on this matter as well as mine does the same kinda![/b]

I posted this question a while back and got an answer from another user. I followed thier advice, and it worked. A/C works fine again. ....It was a bad blower motor resistor. Got a new one and installed it myself, and everything's fine again. A word of advice- I tried to purchase the part from 3 local parts stores (chains), and all 3 had to order the part (aftermarket part), and when it arrived all 3 gave me the wrong part. I ended up going to the Mazda dealership and they were able to get me the right part...but for $50 instead of the $25 at local parts stores. Oh well, $50 was worth it to get the AC going again! Good luck!
gief223@sbcglobal.net is offline  
post #4 of 4 (permalink) Old 07-31-2008, 07:52 AM
Mazda Newbie
 
Join Date: Feb 2008
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Blower Motor Resistor for sure, it sits behind the glove box (you must remove it) on top of the fan housing
fburggolfctr@aol.com is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mazda Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome