Mazda 3 airbag sensor issue - Info from dealer - Mazda Forum

MazdaWorld.org is the premier Mazda Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 01-20-2004, 02:09 PM
Mazda Newbie
 
Join Date: Dec 2003
Posts: 13
Default

Just an update...

It has been 2 weeks now since my dealer took my car back into the shop. After many false promises of returned calls, etc from mazda canada i finally got to speak to someone today that had what I think was the answer for me.

Appears that there is an issue with the crash sensors in the mazda 3's that has taken mazda off guard in terms of replacement parts. they are trying to round up as many parts as they can, but they said they need to build these parts due to the increased demand and then ship them to the dealers.

They didnt think they were going to have to do a recall on the issue,....just fix the cars as they come in.

This is unfortunately disappointing to say the least to me...the dealer has had my new car longer than I have
Reply With Quote
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 01-20-2004, 07:58 PM
Mazda Newbie
 
Join Date: Jan 2004
Posts: 22
Default

I have been driving my car with the light on for the past 3 weeks.

Had the car since Dec 8 and 2 to 3 weeks later it came on.

They said they would have gotten the sensor as they ordered it for Jan 14th so I called on Monday and they now say back ordered till Some time in Feb.

I bet the current replacement they had were from the original manufacturing batch meaning no good.

This is a major problem as if I get in a accident it will not deploy oh no

Are they giving you a loaner good for you no salt for you car if you have loaner
Reply With Quote
  #3 (permalink)  
Old 01-27-2004, 08:43 PM
Mazda Newbie
 
Join Date: Jan 2004
Posts: 11
Default

Well...My car (3 Sport GT) has been in the shop for a week now due to the Airbag issue. They tell me that it they are not getting parts in until 1st or 2nd week of Feb. So that will be at least 2 or 3 weeks without my new 2004 3, that I am paying for. Not too happy....pay for a new car and they gave me an old protege that stinks and runs like **** from Enterprise rent a car, and will not upgrade me.

Mazda Canada and my dealer will not do anything else for me at this point. Which I am not too pleased about, considering I have only been driving the car for 2 weeks. If anyone out there gets something or anything other than a rental car would you please let me know or post a message? I feel like I am getting screwed on this deal!!

TGH
Reply With Quote
  #4 (permalink)  
Old 01-28-2004, 11:22 AM
Mazda Newbie
 
Join Date: Jan 2004
Posts: 4
Default

I purchased my Mazda 3, 22 days ago. I got it at 7 kms. The first thing I noticed when I drove it off the lot was that the airbag sensor light was on. I took it back 2 days later, but they couldn't "fix" it. I took it back a week later, with no luck. The dealer had it all day yesterday to no avail. I started doing searches on the internet yesterday and found these postings. I talked to Mazda Canada today and they acknowledged that there was a problem and told me that if I wasn't comfortable driving a car with a problem with the airbag system, I could take it to my dealer and they would give me a loaner car until the problem is fixed. They guy at Mazda Canada said that the airbag system is deactivated as long as that light is on. I phone my dealership and they had no idea about this "problem."

Unreal. All together, the dealership has wasted 12 hours of my time, not to mentioned the gas that I had to pay for to drive it back and forth to their facilities while they tried to "fix" this problem. Obviously they haven't been in contact with Mazda Canada, didn't receive any service bulletins OR were lying to me (I asked them yesterday, "Is this a common problem among Mazda 3s" and they told me, "No"). Whichever it is, they have dropped the ball. If you own a Mazda 3 and are having these "airbag light" problems, take it to your dealership.

I feel, that for the distaste that has been my first experience with Mazda, for the time I have invested waiting for them to figure out what the "problem" was, for the time I have had to invest to investigate this problem on my own and bring it to my dealership's attention, the time I am going to have to drive the "lender" vehicle because they are waiting to fix my car and the money I have spent on gas, driving my Mazda 3 back and forth to the dealership - we should receive SOMETHING. This is ridiculous.

And to top it all off, 2 days ago, while I was parked on a side street visiting a friend, somebody skidded out and sideswiped my NEW CAR. I have a nice dent and a few VERY good scratches to proove it. They left no name, no number. I have to file a "hit and run" claim through my insurance. SHITTY deal.
Reply With Quote
  #5 (permalink)  
Old 01-28-2004, 11:46 PM
Mazda Newbie
 
Join Date: Nov 2003
Location: Pickering Ontario
Posts: 31
Default

Mine just came on today so i'll see how my dealer makes out with it....

Fuji
Reply With Quote
  #6 (permalink)  
Old 01-29-2004, 12:32 AM
Mazda Newbie
 
Join Date: Nov 2003
Location: Minnetonka, MN
Posts: 91
Default

Mine came on today too yay hopefully my dealer won't be a complete moron and I can get it fixed. At least the VW got to the first oil change with no problems.
__________________
Email me at msaeger_@_mn_._rr_._com (remove underscores)
Reply With Quote
  #7 (permalink)  
Old 01-30-2004, 05:00 PM
Mazda Newbie
 
Join Date: Jan 2004
Posts: 11
Default

Sorry to hear about your car there Zeeba....Shitty deal! Well it looks like there are more people out there with there with this problem. So letís keep this forum up to date with info. on this issue. I want to see what Mazda Canada and the Dealers are going to do for us on this. Lets fight unitl the end!! haha

TGH
Reply With Quote
  #8 (permalink)  
Old 01-30-2004, 08:59 PM
Mazda Newbie
 
Join Date: Jan 2004
Location: Montreal
Posts: 22
Thumbs down

After reading about this air bag sensor problem, I went to my dealer today to ask for information. He was not to sure about that problem but when I explained to him the complaints I've read on the net (I did not mention this forum explicitly) then he said it had to do with the passenger airbag only and that it did not affect the driver's airbag. My dealer is pretty good but I think he was BSing on that one although the explanation makes some sense. He said it might have to do with the sensor in the seat that checks the weight of the passenger. If there is no one then the airbag should not deploy and the light informs the driver about that.
__________________
=========================
M3-GT-GFX, Titanium 4d 5speed
=========================
Reply With Quote
  #9 (permalink)  
Old 02-02-2004, 12:40 PM
Mazda Newbie
 
Join Date: Nov 2003
Posts: 79
Default

Mz3dude,

He fed you a plate of BS. It's pretty obvious to me, if he explained it the same way you did.

I think the thing is, they don't have a clue. Have they even fixed this issue yet?
__________________
Apexjr
95 Toyota MR2 Turbo - 250rwhp
Reply With Quote
  #10 (permalink)  
Old 02-02-2004, 03:07 PM
Mazda Newbie
 
Join Date: Jan 2004
Location: Montreal
Posts: 22
Default

Quote:
He fed you a plate of BS. It's pretty obvious to me, if he explained it the same way you did.
Ya...I could smell it too when he was saying that...just wanted to share the received info...
__________________
=========================
M3-GT-GFX, Titanium 4d 5speed
=========================
Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 10:20 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.