07 Mazda 5 - transmission random issues - Mazda Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 05-25-2017, 07:06 PM Thread Starter
Mazda Newbie
 
Join Date: May 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
07 Mazda 5 - transmission random issues

Hi everybody. I need some help! I have searched everywhere, even took my 07 Mazda 5 to a transmission shop who had it for 4 hours and still couldn't find the issue.

The problem is, whenever I drive the 5 for about 15 minutes or so, the transmission goes into lip mode (sticks in 3rd gear). Before then, then transmission shifts very smoothly with no issues what so ever. It also throws codes, all of which show all solenoids in the transmission failing. This doesn't make any sense, since 15 minutes before it was shifting and driving just fine. If I shut the car off, let it sit for let's say 1/2 an hour, it goes back to driving just fine again. Everything I have read points to the TCM, which on the 07' 5, I believe is built into the ECM. I would like to know if anyone has seen this issue. I think replacing the ECM would correct the issue. Anyone have this issue before?

I would love to fix this as everything else on the car is in perfect condition.

Thanks in advance for any information you can give me!
criney04 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome