Fixing my EGR problem... - Mazda Forum

MazdaWorld.org is the premier Mazda Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-26-2005, 12:57 PM
9milly7's Avatar
Junior Member
 
Join Date: Feb 2004
Posts: 196
Default

I finally have fixed my EGR problem. I figured that an EGR problem meant that the EGR valve needed to be replaced or cleaned, so i took it off last week and tried cleaning it. There was some carbon buildup in there but nothing too excessive. Last night while driving home the CEL came on again...so it was back to the drawing board. After some research i found out where the EGR ports were in the throttle body, and attempted to clean those.
this is what i found...

i could not even fit a small hex key into the port opening. The left port was completely blocked off, and the right one wasn't too much better. After cleaning and taking the carbon out of the ports, it looked alot better.

so if you get a code for the egr valve flow and cleaning your EGR valve itself doesnt do the trick...try this.
__________________
1997 Sand Mica Milly
-KMC 17s
-Incriminator Audio 187s
-Alpine HU
Reply With Quote
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-26-2005, 02:00 PM
Platinum Member
 
Join Date: May 2003
Posts: 3,783
Default

What was the code you got that signalled the problem. I got a 1195 dode after checking the check engine light and getting codes read. AutoZone said the code meant that the SCP HVCC failed to initiate whatever that means. When I called Mazda the stated it was a problem with the exhaust recirclating but they would have to search the whole system to find out what it actually was. Where exactly is the EGR valve anyway in plave I need to clean it? Any help is appreciated.

M
__________________
95 Millenia w/ J-spec cams, 64 mm TB, UOR pulley, Outlaw Engineering phenolic IM spacers, NGK wires, J/K Autosports CAI, Custom Magnaflow 2.5 inch catback exhaust, Magnaflow 2.5/18 in Free Flow Cat, Eibach springs, J-spec rear sway bar, Hayden 678 tranny cooler, Goodridge SS Braided Brake Lines, KVR crossdrilled rotors, Porterfield Carbon Fiber Pads, Painted Ford Blue calipers, Centerline Impulse Rims, 225/45/17 Toyo T1S tires, and 35% tint. Alpine Head Unit. Pioneer 6x9 in rear deck. !2 in Infinity Sub/ w Bazooka Amp
http://members.cardomain.com/mellinie .

03 Protege 5 w/E-bay CAI, Magnaflow 2.25 in catback exhaust, Konig Holes Rims, 205/40/17 Toyo Proxes 4, and 35% tint, Eibach springs on the rear and the fronts waiting for a warm day to install. http://members.cardomain.com/maceyblue

Give me suggestions to what you think next performance mod ought to be.
Reply With Quote
  #3 (permalink)  
Old 05-26-2005, 04:05 PM
Platinum Member
 
Join Date: May 2005
Location: Houston, TX
Posts: 3,617
Default

Can you take a pic of that area zoomed out a little? I'm having trouble referencing that area on the engine bay.
Reply With Quote
  #4 (permalink)  
Old 05-26-2005, 05:11 PM
9milly7's Avatar
Junior Member
 
Join Date: Feb 2004
Posts: 196
Default

i got a P0400 code...and here are some more pics.

this is where the EGR valve is...


and this is where the EGR ports are...



and yes i know my engine is dirty...and will be getting a full cleaning within the week.
__________________
1997 Sand Mica Milly
-KMC 17s
-Incriminator Audio 187s
-Alpine HU
Reply With Quote
  #5 (permalink)  
Old 05-26-2005, 06:25 PM
Mazda Newbie
 
Join Date: Mar 2005
Location: Enterprise, Al
Posts: 33
Default

I had the same problem, I took the egr valve off, took the throttle body off, made a tool out of a small flat blade screwdriver and cleaned it right on the car. This was about six months ago and no more problem. I can't remember the code number, but it was EGR flow malfunction when autozone scanned it for me. Cost abou $2.50 for a can of fuel injector throttle body spray cleaner.
Reply With Quote
  #6 (permalink)  
Old 05-26-2005, 10:03 PM
9milly7's Avatar
Junior Member
 
Join Date: Feb 2004
Posts: 196
Default

yea i hope this fixes it for me...i've been riding around without an inspection sticker for a few weeks now...
__________________
1997 Sand Mica Milly
-KMC 17s
-Incriminator Audio 187s
-Alpine HU
Reply With Quote
  #7 (permalink)  
Old 05-28-2005, 09:48 PM
Platinum Member
 
Join Date: May 2005
Location: Houston, TX
Posts: 3,617
Default

Thanks for the new pics. That helped a lot. I have to do the same sometime tomorrow.


Reply With Quote
  #8 (permalink)  
Old 05-29-2005, 08:49 AM
SpecialKnetix's Avatar
Silver Member
 
Join Date: Apr 2005
Location: New Hampshire
Posts: 808
Send a message via AIM to SpecialKnetix Send a message via Yahoo to SpecialKnetix
Default

No inspection sticker? That's a $43 ticket here... Anyways, I've heard AutoZone reads codes for free. Is this true? because I think I need to get it done. my CEL has been on for like 3 days solid. not flashing tho.
__________________



"All generalizations are useless....Including this one."

ChiTown: "Buying a millenia, good choice, buying reality's headlights... priceless."

Ellissentials' site for electronic dance music
Reply With Quote
  #9 (permalink)  
Old 05-29-2005, 09:30 AM
tigersan's Avatar
Junior Member
 
Join Date: Feb 2005
Location: Portland, OR
Posts: 406
Default

Quote:
Originally posted by SpecialKnetix@May 29 2005, 05:49 AM
No inspection sticker?* That's a $43 ticket here... Anyways, I've heard AutoZone reads codes for free.* Is this true?* because I think I need to get it done.* my CEL has been on for like 3 days solid. not flashing tho.
[snapback]275508[/snapback]
Yeat autozone reads them for free, but so does Cottman Transmission and if you go there you can get a expert opinion on how to fix it also.

__________________
98 milly L: KLZE, 65mm TB, Pheno spacers,UR underdrive pulley, JK Autosports CAI, MBX AFPR.
Reply With Quote
  #10 (permalink)  
Old 05-29-2005, 10:15 AM
SpecialKnetix's Avatar
Silver Member
 
Join Date: Apr 2005
Location: New Hampshire
Posts: 808
Send a message via AIM to SpecialKnetix Send a message via Yahoo to SpecialKnetix
Default

Ok cool, Thanks........but, I don't think we have a Cottman trans. round here. Never heard of em.
__________________



"All generalizations are useless....Including this one."

ChiTown: "Buying a millenia, good choice, buying reality's headlights... priceless."

Ellissentials' site for electronic dance music
Reply With Quote
Sponsored Links
Advertisement
 
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 10:44 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.