Running issue - Mazda Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 10-02-2018, 01:11 AM Thread Starter
Mazda Newbie
 
Join Date: Oct 2018
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Running issue

I have a 1993 Mazda B2600, pickup idles rough (almost dies at idle after warms up) if I unplug the front plug from the spark plug it idles a lot smoother, has new spark plugs, wires and rotor cap.
Any help greatly appreciated
Dpix is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-14-2018, 11:59 PM
Mazda Newbie
 
Join Date: Oct 2018
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
running issues

ok I own 2 b2600 and 2 mazda b2200,s the two issues that plague the 2600 are rust in the ecm its located down by the kicker plate on the passanger side most times its bad ground problem make sure were you bolt onto the truck are free of rust also may be inside the ecm.the second problem I found is is temp sending unit.there two sending units near the thremost a 2 pin that's the one your looking for the single pin is for you dash gage.use a volt meter turn your volt meter to volt setting. with the key turned on pull the wire from the 2 pin it shud not read more than 5 volts if its over replace sending unit. any one of these shud fix your problem
mazda b crazy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome