2003 protege 5 rhythmic thumping sound - Mazda Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 07-15-2019, 05:14 AM Thread Starter
Mazda Newbie
 
Join Date: Jul 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2003 protege 5 rhythmic thumping sound

Hey there!

I've been having this issue with my protege for a few months now and haven't been able to figure out whats makes the noise. it makes a rhythmic thumping sound when driving at freeway speed and only when makes turns in either direction. I checked the tie rod ends and they were bad so i replaced them both, after replacing them I noticed that the sound stopped coming from the drivers side and now is over on the passenger side, before this noise I have replace the sway bar links, wheel bearings, lower control arms, ball joints and cv axles. all of that about 6 months before the noise started. I've had it checked and aligned after all that work. has anyone experienced this or have any suggestions as to what would make that noise?
Eweeld07 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome