Cruise Control not working 2013 CX-9 - Mazda Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 11-29-2018, 06:56 PM Thread Starter
Mazda Newbie
 
Join Date: Nov 2018
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Cruise Control not working 2013 CX-9

Cruise control on my 2013 CX-9 will not set. When I press the on/off button the amber "Cruise" light comes on but will not set at a speed and the light doesn't go green. I started having trouble with it after a dealer replaced the brake booster. It was intermittently not working to begin with, but now will not work at all.
lightning is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-03-2019, 10:52 AM Thread Starter
Mazda Newbie
 
Join Date: Nov 2018
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have the exact same issue after the dealer changed the brake booster. For a while I could lift up on the brake pedal with my foot and it would set. Now that doesn’t work either.

I’m guessing there’s an adjustment to the switch on the brake pedal that tells the cruise to disengage when brakes are pressed.
lightning is offline  
post #3 of 3 (permalink) Old 12-24-2019, 12:22 PM Thread Starter
Mazda Newbie
 
Join Date: Nov 2018
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I got this fixed. A shop replaced the switch that detects the brake pedal being pressed.
lightning is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome