2000 626 2.5 - Mazda Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 11-29-2019, 12:59 PM Thread Starter
Mazda Newbie
 
Join Date: Nov 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2000 626 2.5

I bought a 2000 626 from salvage it had set for 8 years engine and transmission are good. I’ve rebuilt the fuel system completely. And all of the ignition components but CPS . I can be driving and it will shut off for no reason. I see the tach bottom out then suddenly it will jump straight to 3000 rpm or die completely. Sometimes I can shift to neutral and it starts up while I’m on the roll other times it has to sit for a few minutes. Any ideas. I’ve changed everything including the ecu and switch
Stickyricky is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome