2019 CX-5 Electrical Issues - Mazda Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old Today, 05:21 PM Thread Starter
Mazda Newbie
 
Join Date: Nov 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2019 CX-5 Electrical Issues

I recently purchased s 2019 CX-5, brand new. I'm about a month in, and I'm having a lot of weird electrical issues. The buttons on my steering wheel and climate control area aren't back-lit when it's dark and my headlights are on. I also wasn't able to brighten or dim my dash lights. Also recently had an issue where I was smelling a burning smell, and I believe there is some problem with wiring. I took it to the dealership and they couldn't find anything at all, so they sent me home. It's working as of right now, but I'm worried that there is a bigger issue. Has anyone else experienced this?
randaroo79 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List




Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome