Electrical issue! - Mazda Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 05-28-2018, 07:02 PM Thread Starter
Mazda Newbie
 
Join Date: May 2018
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Electrical issue!

Hi all,
I have a problem and would like to address it myself if I can narrow it down. I have a new battery roughly 5. I this old, my battery kept dying over the weekend and I got it tested at autozone who said the alternator was bad. So I replaced it and over the weekend of sitting the car wouldn't start at all. Went back and the error was the same for the new alternator, "voltage regulator failed". During the week the car starts up and drives fine. There are no lights on the dash, I haven't hooked up a obdII scanner to it yet, but I'm just stuck as to what is draining my battery over the weekend but fine during the week. I do have an aftermarket radio and subs but haven't yet tested if it's drawing power when the car is off. Does anyone have any thoughts on this.
Adam is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-09-2018, 07:23 AM
Mazda Newbie
 
Join Date: Oct 2018
Location: Somewhere in England...
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Check the engine ground leads, remove them, clean both sides and reinstall with some light lithium grease to keep them from corroding. That would also be good for the battery leads and posts.
Hero777 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome