Mazda Forum - Reply to Topic
Thread: Connector for the coolant temp sensor that goes to the ECU Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Mazda Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
01-29-2019 02:37 PM
BuzzBates Yes, Scott is great. Thanks for the link. The part is on its way. Hope it fits, and pretty sure it will.
01-28-2019 09:55 AM
Cussboy Ask Scotch at B2600i.com
01-27-2019 07:51 PM
BuzzBates
Connector for the coolant temp sensor that goes to the ECU

Both wires have pulled loose and I can't find the correct connector to replace it. For now I drilled out each connector and then tinned the wire and stuck it in. but today it got loose again and the truck started running bad again. Any idea where I can get the connector. I've checked local auto parts stores and online and they have one that's supposed to fit but it doesn't. Help please.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome